btnSay 치는것부터 막혔네요ㅠㅠ > QnA

본문 바로가기

사이트 내 전체검색

QnA

안드로이드 btnSay 치는것부터 막혔네요ㅠㅠ

페이지 정보

barezebe119 20-10-15 17:53 조회 100회 댓글 9건

본문

barezebe119님의 댓글

profile_image barezebe119 작성일

지금 여러가지 시도해보면서 직접 "import kotlinx.android. ~~~ " 도 쳐봤는데 아예 kotlinx를 인식을 못하고 빨간글자로 표시되네요..ㅠ

케빈키스너님의 댓글의 댓글

profile_image 케빈키스너 작성일

저도 똑같은 증상입니다.
이것저것 다해보다가 안드로이드스튜디오3.5(android-studio-ide-191.5791312-windows)를 설치하니까 되네요. ㅠ

barezebe119님의 댓글

profile_image barezebe119 작성일

저도 버전 3.5로 바꾸니까 되긴하네요! 감사합니다.
그래도 최신버전은 왜 안되는지 궁금하네요...

케빈키스너님의 댓글의 댓글

profile_image 케빈키스너 작성일

환경설정을 바꿔야할거같은데..구글링해도 방법을 못찾겠네요.

Scott님의 댓글의 댓글

profile_image Scott 작성일

build.gradle 에 코틀린 익스텐션을 추가해야 합니다.

https://flow9.net/bbs/board.php?bo_table=android&wr_id=25

barezebe119님의 댓글의 댓글

profile_image barezebe119 작성일

알려주셔서 감사합니다!

ihopi님의 댓글

profile_image ihopi 작성일

Android 4.1 버전에서 신규 프로젝트 생성 시 기본 플러그인으로 더 이상 kotlin-android-extensions 가 제공되지 않네요.
저도 좀 당황스러워서 찾아보다 보니, 여러가지 이유로 이걸 제공하고 있지 않습니다.

해결방법은 세 가지가 있는데요. kotlin extensions를 수동으로 추가하거나, 아니면 findViewById를 사용하거나 이도 아니면 4.2 Preview에서 기본으로 제공되는 View Binding을 사용하면 됩니다.
알아두실 것은, kotlin-android-extensions는 구글이 직접 삭제했기 때문에 향후 추가 될 일은 없을 듯 합니다. 그래서 이번에 View Binding을 사용 해 보았는데, 생각보다 굉장히 편하네요.
간단하게 설명할 것은 아니라서 책의 저자님께서 한 번 영상강의를 만들어 주시는게 좋을 듯 합니다.

아무튼 안드로이드 스튜디오 최신버전 받아놓고서 책의 처음부터 실행이 안되는 현상으로 놀라셨던 분들 께서는 당황하는 일 없으셨으면 좋겠습니다.

케빈키스너님의 댓글의 댓글

profile_image 케빈키스너 작성일

아 그렇군요..상세한 답변 감사합니다~

gdlseed님의 댓글

profile_image gdlseed 작성일

후....저두 안되길레 몇번을 재설치 한지 모르겠네요 ㅠㅠ

Copyright © flow9.net All rights reserved.